I agree with part of the article, because I didn't read the rest. I truly dislike the use of single letter variable names: f, g, h and foo, bar, baz. My advice: use descriptive variable names.
function twoIfs, function complicatedIf, var simpleAnd, etc. Makes it so much easier to read examples instead of remembering "oh yeah, f had two ifs in it, h had the if/else, g calls f which calls h which,...".
Also see this often in other examples: "A for 'Truthy variable' " 😓 Wtf. Laziness is good when it makes things easier, not harder.